HELP!!!

We are having major NMAS login problems with VPN Client users. We
have tried both v3.8.7 and V3.8.9.

'The VPN Client error reads Failed NMAS Authentication etc etc NMAS Error
FFFFF98C'.

At the same time

CSAUDIT reports :
Failed to process NMAS request. Failed to authenticate NMAS connection
Error = 0x1

NMASLOG reports :

10: Sequence Selected == "NDS"
10: Login Method 0x00000007
10: MAF_GetAttribute LSM 0x00000007 AID: 2
10: MAF_GetAttribute LSM 0x00000007 AID: 1 Value: USER.CONTEXT
10: MAF_Begin LSM 0x00000007
10: <<ServerPut: message size=8 queue size 0
10: <<ServerPut: message size=5 queue size 8
10: MAF_AllowPasswordSet LSM 0x00000007
10: ERROR: -1697 MAF_GetPassword LSM 0x00000007
10: MAF_Write LSM 0x00000007
10: <<ServerPut: message size=8 queue size 13
10: <<ServerPut: message size=40 queue size 21
10: MAF_GetNDSPasswordHash LSM 0x00000007
10: MAF_XWrite LSM 0x00000007
10: <<ServerPut: message size=56 queue size 61
10: MAF_XRead LSM 0x00000007

Notes :
* I have replaced the real username with USER.CONTEXT
* Note - ERROR: -1697 MAF_GetPassword LSM 0x00000007

NRM Audit Log reports :

AUTH Gateway Failed to process NMAS request. Failed to authenticate NMAS
connection. Error = 0x1.

Our server configs are as follows :

NetWare 6.5 SP3
BorderManager 3.8 SP3

Single Tree :

[Root]
O=Site A (Master Replica) - Partition created
O=Site B (Read/Write Replica) - Partition created

Site A contains the BM MASTER, Site B contains the BM SLAVE.

S2S VPN is working fine by the way, although we can't get the
MASTER out of the 'Being Configured' state...

Thanks in advance..

Cheers,

Richard.