we ran into some problems during the upgrade of our OES2. Somehow, it did
not install the new kernel, maybe, because we had some trouble with the
rpm database.
The server comes up, even the gui, but the volumes and
partions are not loaded, also no network stack beeing loaded. The good
point: Partition tables are ok, and we could mount the partitions and do a
copy with the rescue cd.

I have a few general questions:
1) If your OES2 is not on the newest patch level, what problems could
occur when you upgrade to SP1? Is this *very* important for the update

2) What happens, if you just update to SLES 10SP, clean up the system and
then update afterwards to OES SP1? From what I have read here, this is not
a good (or even not supported) way for doing the upgrade?

3) If your eDirectory Update fails (because of Time sync or other sync
issues) - can you do the migration later on as you could do in Netware?

To get our sys working:
we tried to repair/rebuild our rpm database, because it did not get the
latest OES updates before the Server down update. So we mistakenly thought
it will be built again with the SP2 update - I guess thats why the system
got messed up.

How can we do a proper rebuild of the db? Do we need that before the
What happens, if we try the install from SLES 10 SP2 media over
the existing system? For some unknown reason, it reported some trouble
with the raid controller driver (which is an ICP Adaptec, normally built
in the distro), but then, it seemed to work - but it did not. It looks
like some modules got updated, some not - and the kernel is still the
SLES 10 SP1 Kernel..
I tried booting the system, and add the SP DVD and started YOU, but it
could not mount the DVD drive...

Would it be possible to boot from the rescue dvd, mount the root and
partitions, and do Install with SP2 (or even first SP1). What could be the
best method to get it working?

Well, any thoughts are welcome..