Hi everyone,

I tried to upgrade an OES1 to OES2 SP1. The main problem is, that the OES1 was updated to eDir 8.8 SP2 via the rug channel a few months ago.
The OES1 was also well patched via rug.

First, I tried this in VMWare before starting it in my productional environment. But I thought as much, it does not work out of the box!

So here is what i found out:
The upgrade procedure stops after the first reboot at beginning the eDirectory upgrade.

The error is similar to the following Novell TID (3484188) "n4u_send_command failed..." upgrading to eDirectory 8.8.2

The "n4u_send_command failed ..." error means that the ndsd could not start. Normally a "instances.0" file will be created in the /etc/opt/novell/eDirectory/conf/.edir Directory. That doesn't work.
The /var/opt/novell/eDirectory/log/ndsd.log shows the following error:

 Dec 21 01:29:11 NCPShim Init Failed, error -5984
Dec 21 01:35:31 Path of Novell eDirectory configuration file /etc/opt/novell/eDirectory/conf/nds.conf
Loader Failed:for /opt/novell/eDirectory/lib/nds-modules/libncpengine.so,error /opt/novell/eDirectory/lib/nds-modules/libncpns.so: undefined symbol: _ZN13SMEntryHandle17nextReferenceToMeEPj,errno 2
In the Novell TID named above in the resolution is the hint, that lib files of an old IDM are still there. IDM is not installed but an older version of eDirectory (8.8 SP2).
And the "undefined symbol error" in the ndsd.log also looks like old lib files.

So I suggest the upgrade procedure of OES2 SP1 cannot handle eDirectory Versions other than 8.7.3. The old nds lib modules will not be deleted.
So I was looking for nds-modules in /usr/lib and there I found the nds-modules directory with all the old lib files in there, e.g. the libncpengine.so and the libncpns.so named in the ndsd.log
So i deleted this directory.
The actual nds modules of eDir 8.8 SP4 are in /opt/novell/eDirectory/lib/nds-modules
this directory does exist and the actual lib*.so files too.

So i started the upgrade process again.... but...
the same error appears.....

So, whats wrong and first of all: how to upgrade my productional server ??

Novell Guys out there, it's your turn now :-)