I have been trying to set up a ZCM 10 server as a proof of concept and Ive run into a problem.

PXE booting works (as in bringing up the PXE menu) after installing 10.1

PXE booting fails after installing the 10.1.1 update.
what happens is this.
When a workstation is booted with PXE enabled, PXE detects DHCP and is assigned the correct IP configuration details.
Press F8 for menu of boot servers, this gives us two options.
- Novell Preboot Server –
- Boot from local devices
We choose the Novell Preboot Server – option then get
“Bootserver IP:
Novell Preboot execution PXE agent v10.1.2.0
Sending queries to
Contacting Novell Preboot Policy services....Done
PXE-M0F: Exiting Broadcom PXE Rom”

Boot of PC then continues as normal.

Tried updating to the 10.1.2a patch, but this made no difference.

I have found a number of forum article pointing to TID 7001179. We have tried this, and even tried setting CLEARTEXT=TRUE, and no change has been found.

Basically this is a summary of the testing we have done.

Theory: Incompatible/older PC’s?
Test: PXE booting with four different new and old PC models
Result: No change

Theory: TFTP directory in wrong location?
Test: Tried renaming TFTP directory and restarting TFTP service
Result: TFTP Service failed to start with renamed directory

Theory: Services not running?
Test: Shutdown services one at a time
Result: Error message varied for each shutdown service

Theory: HTTP Ports Incorrect?
Test: Checked correct HTTP port specified in novell-zenimgweb.conf file
Restarted service with CLEARTEXT=TRUE
Result: No Change

Theory: Switch blocking traffic
Test: Connect directly to server with cross-over cable
Result: No Change

Theory: Firewall blocking traffic
Checked: Firewalls are off
Result: No Change

Windows 2K8 x64 running on Hyper-Vr on a Windows 2K8 x64 box.
To rule out Hyper-V being an issue, I built a new server with just Win 2K8 x64 and had the same results.

Tried building a 2K3 VM on Hyper-V and installing ZCM on this.
PXE boot menu works fine after installing the patches so looks like it may be a 2K8 issue?

Also tried the ZCM patches before and after applying the MS 2K8 updates to rule them out of being the issue.