Home

Results 1 to 5 of 5

Thread: Running multiple MTA's on same server and the soapport

Hybrid View

  1. #1
    JJB NNTP User

    Running multiple MTA's on same server and the soapport

    Hello, upgraded to GW8 (running on NW65SP8) on Friday night, using the
    Caledonia guide. In the guide (p.31) as well as at
    http://www.novell.com/communities/no...ta-same-server
    there is mention about adding a soapport switch to the MTA startup file if
    you have more than one MTA on the same NetWare (or Linux) server so that
    there won't be a port conflict between the 2 MTA's. As part of my upgrade I
    tried doing this but faced problems so I ended up removing the switch and
    everything (AFAICT) is running OK? Specifically issues were:

    - After loading the primary domain (didn't put a soapport which means that
    it will use the 7161 default), there was no 7161 port showing in TCPCON

    - I put the /soapport in the secondary domain and loaded the MTA, but I
    initially got on the console screen:
    DIS: Error initializing SOAP: [8558]
    DIS: SOAP is not enabled

    - 7162 showed in TCPCON until the error appeared, then went away. I
    unloaded both MTA's and put the 7161 port in the primary domain file too,
    and reloaded. The same thing happened on the secondary.

    - Both the MTA switch and the error code do not show up in the documentation
    or in searches on Novell's site, nor does the /soapport switch show in the
    newly created MTA startup file (I had it recreate the startup file then did
    a compare - so that I could see any new startup switches).

    - Removed the /soapport switch for both domains, no errors, and TCPCON
    doesn't show either 7161 or 7162.???

    I was talking with Novell tech services on another GW8 issue (GWDCA which I
    posted in the agents forum), and he knows nothing about a soapport in the
    MTA, only the POA. He's checking with others and will revert if anything
    found.

    Am I missing something?

    TIA
    James



  2. #2
    Join Date
    Aug 2007
    Posts
    2,892

    Re: Running multiple MTA's on same server and the soapport

    Not sure - but I can duplicate it here over and over if I don't put the soapport in, so it might depend on a number of issues I guess. The soapport on the MTA is truly not used for ANYTHING right now, so if it's not listening I wouldn't worry. So, putting the switch in there is mostly for "fixing" things if you can't load the second MTA due to the soapport problem.

  3. #3
    JJB NNTP User

    Re: Running multiple MTA's on same server and the soapport

    I was talking with NTS on another issue after my initial post and they say
    that it's an undocumented switch (this was another tech). Whether that
    means that he knows about it and it's not published yet, or he didn't know
    what I was talking about when he said undocumented, is unclear to me.

    I have to load my POA's on individual IP addresses now (due to the GWDCA
    loading issue - Novell recommendation), so I guess if I see a problem with
    the MTA and I can't figure out the soapport, I can always load the secondary
    MTA on another IP...

    BTW when the problem showed up for you, was it under SLES or NetWare? I'm
    running NetWare for now (NW65SP8).

    Cheers
    James

    "dzanre" <dzanre@no-mx.forums.novell.com> wrote in message
    news:dzanre.3lykup@no-mx.forums.novell.com...
    >
    > Not sure - but I can duplicate it here over and over if I don't put the
    > soapport in, so it might depend on a number of issues I guess. The
    > soapport on the MTA is truly not used for ANYTHING right now, so if it's
    > not listening I wouldn't worry. So, putting the switch in there is
    > mostly for "fixing" things if you can't load the second MTA due to the
    > soapport problem.
    >
    >
    > --
    > Danita Zanre
    > Novell Support Forums Sysop
    > http://www.caledonia.net/blog
    > ------------------------------------------------------------------------
    > dzanre's Profile: http://forums.novell.com/member.php?userid=364
    > View this thread: http://forums.novell.com/showthread.php?t=356535
    >




  4. #4
    Join Date
    Aug 2007
    Posts
    2,892

    Re: Running multiple MTA's on same server and the soapport

    Yes, it's an undocumented switch (well, at least by Novell - it is of course documented in my book <heehee>) - seems to be most problematic on Linux. Every once in awhile they throw in functionality that they know will be "needed in the future" and it bites us <g>. The hidden soap switch in early POAs was like that as well.

  5. #5
    JJB NNTP User

    Re: Running multiple MTA's on same server and the soapport

    OK thanks, I still have all NetWare installs but have updated my GW upgrade
    notes to mention about the soapport when moving to Linux. Thanks for the
    heads up.

    Cheers
    James

    "dzanre" <dzanre@no-mx.forums.novell.com> wrote in message
    news:dzanre.3lyukn@no-mx.forums.novell.com...
    >
    > Yes, it's an undocumented switch (well, at least by Novell - it is of
    > course documented in my book <heehee>) - seems to be most problematic on
    > Linux. Every once in awhile they throw in functionality that they know
    > will be "needed in the future" and it bites us <g>. The hidden soap
    > switch in early POAs was like that as well.
    >
    >
    > --
    > Danita Zanre
    > Novell Support Forums Sysop
    > http://www.caledonia.net/blog
    > ------------------------------------------------------------------------
    > dzanre's Profile: http://forums.novell.com/member.php?userid=364
    > View this thread: http://forums.novell.com/showthread.php?t=356535
    >




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •