After downloading the update from the console and trying to apply it to a device i get the following error:

The Update for ZCM (10.1.2a)
update requires the following update(s) to be applied before it can be deployed:
Update for ZCM (10.1.1)

- ran a report on all devices to see the versions of zenagent. All devices show as having 10.1.1

Can I manually install 10.1.2 or will that completely mess things up?