OES SP2 Server 2.6.5-7.314-smp i686 athlon i386 GNU/Linux
hardware RAID and LVM

My problem is that upon reboots following a kernel update the device
number as seen by the stat command changes, e.g.:

stat examplefile
before reboot
Device: fd0ah/64778d Inode: 10617599 Links: 1

after reboot
Device: fd05h/64773d Inode: 10617599 Links: 1

As a consequence all files on all volumes will get a full backup by gtar
instead of a scheduled incremental one. This is more data than my backup
system can take per night. Newer versions of gtar (OES SP2 uses
tar-1.13.25-325.10) offer the option --no-check-device which might
resolve this issue. But then this looks more like a kernel bug to me
than as a good reason to upgrade tar which well might break other things.
Any suggestions for a workaround or proper solution are highly welcome.
The trivial workaround is to exclude some partitions from backup after a
reboot. But then there might be some smarter way to deal with this issue.