Well I seems like I am now privileged to have this issue! It seems to be an issue when sending certain attachments, mainly PDFs. Hopefully Massimo and the rest of the gurus have an idea!

10:34:35 47A DMN: MSG 150708 Send Failure: 420 TCP write error
10:34:35 1BA MSG 150708 Analyzing result file: GWPO/VOL1:\GW\GWDOMAIN\WPGATE\GWIA\result\r9881d87.245
10:34:35 1BA MSG 150708 Command: house.mi.gov
10:34:35 1BA MSG 150708 Response: 220 smtp2.legislature.mi.gov
10:34:35 1BA MSG 150708 Command: EHLO gw.hollandpublicschools.org
10:34:35 1BA MSG 150708 Response: 250 ok
10:34:35 1BA MSG 150708 Command: MAIL FROM:
10:34:35 1BA MSG 150708 Response: 250 Ok
10:34:35 1BA MSG 150708 Command: RCPT TO:
10:34:35 1BA MSG 150708 Response: 250 Ok
10:34:35 1BA MSG 150708 Command: DATA
10:34:35 1BA MSG 150708 Response: 354 Start mail input; end with .
10:34:36 1BA MSG 150708 Detected error on SMTP command
10:34:36 1BA MSG 150708 Command: Data...
10:34:36 1BA MSG 150708 Response: 420 TCP write error
10:34:36 1BA MSG 150708 File: GWPO/VOL1:\GW\GWDOMAIN\WPGATE\GWIA\wpcsin\4\49881dbc.i2 3 Message Id: (4988640C.C2F:152:15407) Size: 1.0 Kb
10:34:36 1BA MSG 150708 Deferring message: GWPO/VOL1:\GW\GWDOMAIN\WPGATE\GWIA\defer\s9881d87.245

Version
GW 8HF1
NW 6.5SP8
Running on ESX 3 server
With two NICs (virtual on two separate subnets.)

Here is our layout

GWPO ---> BDRMGR NAT ---> PIX (at our ISP) ---> Cloud

Currently we don't have any packet filters funning on BRDR.
I have confirmed with our ISD that ICMP filtering is turned off for our IP address. The mtu limit at the PIX is 1500.
I have checked the nic speeds to see if they negotiated properly. My links that are 100 mb are set manually, the GB ports are at auto (so there is a mix).

I have tried:
Set USE SPECIFIED MTU = ON
SET MAXIMUM INTERFACE MTU = 1492
SET TCP PATH MTU BLACK HOLE DETECTION AND RECOVERY = ON
And it still is not happy.

I have done some packet captures but havent really seen much, maybe I dont know what I am looking for.

Thanks for your help.
Clark