Hello all,
quick question, can you upgrade from BM3.5 to BM3.8?