Hi,
As I could see it was possible, I tried to upgrade BM3.5 to BM3.8
but I cannot go further the Minimum Requirements screen
claiming NBM 3.6.2A

Any idea ?