Hello All;

First OES2 SP1 server ina a NW 5.1 eDir. NW5.1 has 8.85c eDir and using the Deployment Manager, updated the schema.

SLES 10 SP2 installed, OES2 SP1 installed. Master and replicas on all NW5.1 servers, No replica on OES2 server. Put a replica on the OES2 server, which did not solve.


When I goto iManager, Storage (or anything where I need to brows the eDir) the eDir browse popup box displays
---
Error: Directory Search Failure

(Error -785) The database subsystem has encountered an error not mapped to an existing NDS error.
----
Details of the error
-----
Object Selector state:

OS.AdvancedSelection = false
Determining starting container/context...
In SearchTokenPost state...
Using OS.Container param = [root]
OS.Mode = Browse
OS.NameFilter = *
Starting container = [root]; cached it!
OS.TypeFilter = NCP Server,NCS:NetWare Cluster,Server
m_bMatchAllTypes = false
m_bMatchAllContainers = false
m_bMatchLeafObjects = false
m_bMatchNonPartitionedContainers = false
m_bMatchAllPartitions = false
m_bShowGlue = false
OS.SearchSubContainers = false
OS.ShowSubClasses = false
OS.SearchOnStartup = defaulting to false
OS: OS.SearchOnStartup = true


Object Selector debug trace:

OS URL = /nps/servlet/webacc
?BQContext=[root]
&BQNameFilter=*
&OS.AdvancedSelection=false
&OS.AuthName=undefined
&OS.Container=[root]
&OS.Mode=browse
&OS.NameFilter=*
&OS.ResultsPerPage=22
&OS.SearchSubContainers=false
&OS.ShowSubClasses=false
&OS.TypeFilter=NCP Server,NCS:NetWare Cluster,Server
&Search.ContextId=
&SearchToken=SearchTokenPost
&User.context=
&error=dev.GenErr
&merge=fw.OS.BrowseResultsSS
&taskId=fw.ObjectSelector
Cache size on entrance = 24
Search.ContextId=
SearchCmdToken = SearchTokenPost
OS.Multiselect = defaulting to false
OS.ResultsPerPage = <22>
OSAnchor already initialized.
>performInit: Performing INIT...
performInit: Search.PseudoObjects = <...>
<performInit: Completed INIT...
>performPost: Performing POST...
performPost: Cached Search.ContextId = fw.OS5
performPost: Put Search.ContextId = fw.OS5 in property object.
performPost: Getting oe for m_strContainer = [root]
performPost: Set search context Container oe = .FSCTREE.
performPost: Set result modifier for search =
performPost: ERROR -- getObjectEntry or getChildren failed, e = com.novell.admin.common.exceptions.UniqueSPIExcept ion: (Error -785) The database subsystem has encountered an error not mapped to an existing NDS error.
showSearchResults: Searching from = .FSCTREE.
showChildEntries: Entering...
showChildEntries: Exiting. Displayed 0 of 22 entries...
showSearchResults: Exiting...
<performPost: Completed POST...
Cache size on exit = 25
------

So the issue is
performPost: ERROR -- getObjectEntry or getChildren failed, e = com.novell.admin.common.exceptions.UniqueSPIExcept ion: (Error -785) The database subsystem has encountered an error not mapped to an existing NDS error.
-----
What?
Any suggestion on how to solve.