We're having trouble with directory quota's in that they don't appear to
work correctly.

I created a directory and set a limit of 64k on it and then copied a file
that is larger than 64k into it. No problem so far. I tried to copy
another file into it and that one did not work (good so far - it did create
a 0 byte file which is another headache but not really the issue). Now if I
copy the file that is already in the directory and paste a copy of it (in
windows explorer) - it works and I can repeat this as many times as I care
to do so.

I ran a rebuild on the pool in question and it still allows me to keep
copying. NW65 SP7.

Do I need to have the classicDirectoryQuotas option turned on?

I thought perhaps windows was caching the write so I verified that all of
the copies of the files are really there on another computer.