...since OES2 SP1 revs eDirectory to 8.8.4 64 bit as well (and you don't have a choice in the matter) things that hook in to eDirectory like...

Novell Audit 2.0.2 Agents
IDM 3.5.1/3.6
(possibly others)

...do not currently work. Until these other products are rev'ed to versions compatible with 64 bit eDirectory, you may want to hold off.

I'm not dissing Novell, just a caveat to anyone upgrading to this version. Be advised. (That being said, it SURE would have been nice had they released updated software that DID work with 64 bit eDirectory on its release date. :)