I currently have BM3.5 installed on my server I want to upgrade to BM3.8
however when I went through the install of 3.8 it threw me out asking for
either 3.6 or 3.7 to be install prior to installing 3.8. I have an
Evaluation copy of 3.7, my question is if I install 3.7 Eval will it
allow me to then go to 3.8 even though I have installed an Eval copy?

Thanks