When I try to send a WOL packet from the server (even to a workstation on the same vlan), I get no magic packet and an error in loader-messages.log:

[DEBUG] [3/4/09 10:34:11 AM] [] [Loader.QueueRunner] [Handler failed to process action ID : 193, Type: WOL_QUICK_ACTION_TYPE, ] [Handler failed to process action ID : 193, Type: WOL_QUICK_ACTION_TYPE, ] [] []
[DEBUG] [3/4/09 10:34:11 AM] [] [Loader.QueueRunner] [java.lang.NullPointerException
at com.novell.zenworks.loader.modules.NetworkInterfac e.convertIPStringToBytes(NetworkInterface.java:92)
at com.novell.zenworks.loader.modules.NetworkInterfac e.getSubnetAddress(NetworkInterface.java:68)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vice(WOLUtil.java:140)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vicesIntoSubnet(WOLUtil.java:97)
at com.novell.zenworks.loader.modules.WakeOnLANHandle r.processAction(WakeOnLANHandler.java:304)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.processAction(QueueThreadWorker.ja va:193)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.run(QueueThreadWorker.java:139)
at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)
] [java.lang.NullPointerException
at com.novell.zenworks.loader.modules.NetworkInterfac e.convertIPStringToBytes(NetworkInterface.java:92)
at com.novell.zenworks.loader.modules.NetworkInterfac e.getSubnetAddress(NetworkInterface.java:68)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vice(WOLUtil.java:140)
at com.novell.zenworks.loader.modules.WOLUtil.groupDe vicesIntoSubnet(WOLUtil.java:97)
at com.novell.zenworks.loader.modules.WakeOnLANHandle r.processAction(WakeOnLANHandler.java:304)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.processAction(QueueThreadWorker.ja va:193)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.run(QueueThreadWorker.java:139)
at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)

If I select a workstation as a proxy, the magic packet get sent and works as expected.

ZCM 10.1.3 on Windows 2003 R2