I am setting up a new OES2 server and everything installs fine except iFolder.
The server is a HP DL320 G5p. The swap and / are on 1 160 gig sata drive and the /var is on a separate 250 gig sata drive. This is going to be a iFolder server for a group of Macs so this is crucial.

I have gone through the process of removing ifolder and reinstalling it several times and it still fails. The simias-server-setup fails also with the following error.

LdapException: (91) Connect Error
System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received form server.
at Mono.Security.Protocol.Tls.Handshake.Client.TlsSer verCertificate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000]
at Mono.Security.Protocol.Tls.Handshake.Client.TlsSer verCertificate.ProcessAsTls1 () [0x00000]
at Mono.Security.Protocol.Tls.Handshake.HandshakeMess age.Process () [0x00000]
at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMess age:Process ()
at Mono.Security.Protocol.Tls.ClientRecordProtocol.Pr ocessHandshakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000]
at Mono.Security.Protocol.Tls.RecordProtocol.Internal ReceiveRecordCallback (IAsyncResult asyncResult) [0x00000] --- End of inner exception stack trace ---

at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHand shakeCallback (IAsyncResult asyncResult) [0x00000]
at Novell.Directory.Ldap.LdapResponse.chkResultCode () [0x00000]
at Novell.Directory.Ldap.LdapConnection.chkResultCode (Novell.Directory.Ldap.LdapMessageQueue queue, Novell.Directory.Ldap.LdapConstraints cons, Novell.Directory.Ldap.LdapResponse response) [0x00000]
at Novell.Directory.Ldap.LdapConnection.Bind (Int32 version, System.String dn, System.SByte[] passwd, Novell.Directory.Ldap.LdapConstraints cons) [0x00000]
at Novell.Directory.Ldap.LdapConnection.Bind (Int32 version, System.String dn, System.String passwd, Novell.Directory.Ldap.LdapConstraints cons) [0x00000]
at Novell.Directory.Ldap.LdapConnection.Bind (System.String dn, System.String passwd, AuthenticationTypes authenticationTypes) [0x00000]
at Novell.Directory.Ldap.LdapConnection.Bind (System.String dn, System.String passwd) [0x00000]
at Novell.iFolder.Utility.LdapUtility.Connect () [0x00000]
at Novell.iFolder.SimiasServerSetup.SetupLdap () [0x00000]
at Novell.iFolder.SimiasServerSetup.Configure () [0x00000]
at Novell.iFolder.SimiasServerSetup.Main (System.String[] args) [0x00000]


I have verified ldap functionality from another computer. I have recreated the server certificates. I have run simias-server setup with ldap secure and unsecured - I get a different error then though. NDS is installed and running, iManager is working fine, LUM is working fine, no NSS volumes on the server. I need somewhere to go with this. There must be a configuration file wrong.