Using ZLM72 fully patched and mirrored SLES10-SP2-Updates and OES2-SP1-Updates channels and applied it to my iFolder server running kernel-vmi 0.34, virtualized in esx. Cannot apply these patches cuz of this:

12 Mar 2009 12:51:07 INFO BundleManager Bundle preparation failed: Unresolved dependencies:
Updating mono-data-1.2.2-12.22.i586[System packages] to mono-data-1.2.2-12.24.i586[Mandatory Bundles]
mono-core-1.2.2-12.22.i586[Mandatory Bundles] provides mono-core == 1.2.2-12.22, but another version of that package is already installed.
mono-core-1.2.2-12.22.i586[System packages] provides mono-core == 1.2.2-12.22, but is scheduled to be uninstalled.
Can't satisfy requirement mono-core == 1.2.2-12.22 for mono-data-1.2.2-12.22.i586[System packages]
Can't install mono-data-1.2.2-12.24.i586[Mandatory Bundles], since mono-data-1.2.2-12.24.i586[Mandatory Bundles] is already marked as needing to be installed
Marking this resolution attempt as invalid.

12 Mar 2009 12:51:07 ERROR ScheduledActionsModule Novell.Zenworks.Zmd.BUNDLE_INSTALL_ERROR: Novell.Zenworks.Zmd.BUNDLE_INSTALL_ERROR
Novell.Zenworks.Zmd.Public.ZenException: Failed to prepare bundles for install: Unresolved dependencies:
Updating mono-data-1.2.2-12.22.i586[System packages] to mono-data-1.2.2-12.24.i586[Mandatory Bundles]
mono-core-1.2.2-12.22.i586[Mandatory Bundles] provides mono-core == 1.2.2-12.22, but another version of that package is already installed.
mono-core-1.2.2-12.22.i586[System packages] provides mono-core == 1.2.2-12.22, but is scheduled to be uninstalled.
Can't satisfy requirement mono-core == 1.2.2-12.22 for mono-data-1.2.2-12.22.i586[System packages]
Can't install mono-data-1.2.2-12.24.i586[Mandatory Bundles], since mono-data-1.2.2-12.24.i586[Mandatory Bundles] is already marked as needing to be installed
Marking this resolution attempt as invalid.

Any ideas?