Is Groupwise 7.0.3 WSDL compatible with Java 1.4? I am aware of removing gwTrace and gwTraceMessage. However, I wonder if the new streaming Attachments is expected work when the WSDL is generated to Java 1.4, (for e.g. if XMLStreamReader is used, which was not yet introduced in Java 1.4)? If Groupwise is compatible with Java 1.4, do you have a pre-generated Groupwise Java 1.4 jar at all, as I am having terrible problem with missing classes, e.g., instead of a,(also all sub-classes of Mail) and being gererated (by JPublisher), I have references to a SOAPElement e.g. in I have a javax.xml.soap.SOAPElement instead of a Mail item.