Home

Results 1 to 2 of 2

Thread: XML Problem

  1. #1
    Rainer Backes NNTP User

    XML Problem

    Hi Preston, Hi all,

    I have another Problem:

    Doing a ReadCursor I get the follwoing document:
    <?xml version="1.0"?>
    <SOAP-ENV:Envelope xmlns:xsd="http://www.w3.org/1999/XMLSchema"
    xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
    xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
    xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
    <SOAP-ENV:Header SOAP-ENV:encodingStyle="">

    </SOAP-ENV:Header>
    <SOAP-ENV:Body
    xmlns:types="http://schemas.novell.com/2003/10/NCSP/types.xsd"
    SOAP-ENV:encodingStyle="">
    <readCursorResponse> <items>
    <item internet="1" xsi:type="Mail"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

    <id>48A9AFB2.EMA.test.100.1623972.1.69.1@1:7.EMA.t est.100.0.1.0.1@16</id>
    <version>1</version>
    <modified>2008-08-18T15:21:54Z</modified>
    <container>7.EMA.test.100.0.1.0.1@16</container>
    <created>2008-08-18T15:21:16Z</created>
    <status/>
    <msgId>48A9AFB2.EMA.test.200.200002C.1.5.1</msgId>
    <messageId>&lt;48A9AF8C.10C8.00AF.0@bond.de&gt;</messageId>
    <source>received</source>
    <delivered>2008-08-18T15:21:54Z</delivered>
    <security>Normal</security>
    <subject>High Priority Sissi Assets 5.0% nach Steuern durch
    die berühmte weiÃ*e Prinzessin</subject>
    <distribution>
    <from>
    <displayName>"Rainer Backes"
    &lt;rbackes@bond.de&gt;</displayName>
    <email>rbackes@bond.de</email>
    </from>
    <to>Karl@bond-int.de</to>
    <sendoptions>
    <statusTracking>None</statusTracking>
    </sendoptions>
    </distribution>
    <options>
    <priority>Standard</priority>
    </options>
    <size>3981</size>
    </item>
    <item internet="1" xsi:type="Mail"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

    <id>48A9AFD1.EMA.test.100.1623972.1.6A.1@1:7.EMA.t est.100.0.1.0.1@16</id>
    <version>2</version>
    <modified>2008-08-18T15:24:14Z</modified>
    <container>7.EMA.test.100.0.1.0.1@16</container>
    <created>2008-08-18T15:21:59Z</created>
    <status>
    <opened>1</opened>
    <read>1</read>
    </status>
    <msgId>48A9AFD1.EMA.test.200.200002D.1.4.1</msgId>
    <messageId>&lt;7bfa9a84.004@gw-ema.bond-int.de&gt;</messageId>
    <source>received</source>
    <delivered>2008-08-18T15:22:25Z</delivered>
    <security>Normal</security>
    <subject>GWEMACON Fehler test.EMA</subject>
    <distribution>
    <from>
    <displayName>&lt;GWEMACON@bond-int.de&gt;</displayName>
    <email>GWEMACON@bond-int.de</email>
    </from>
    <to>Karl@bond-int.de</to>
    <sendoptions>
    <statusTracking>None</statusTracking>
    </sendoptions>
    </distribution>
    <options>
    <priority>Standard</priority>
    </options>
    <size>5032</size>
    </item>
    </items>
    <status>
    <code>0</code>
    </status>
    </readCursorResponse>
    </SOAP-ENV:Body>
    </SOAP-ENV:Envelope>

    The first item is the problem. My XML Library isn't able to read the
    <subject> Element from the document.
    Now my question: whose fault is it ? - Is my XML parser wrong or does
    the POA code something strange?
    The garbage characters should be Umlauts, but since 7.0.something
    especially Mails from Exchange contain such carbage.

    Any ideas ?


    Thanks

    Rainer


  2. #2
    Rainer Backes NNTP User

    Re: XML Problem

    .... Problem solved... it was me. (It was neither the library nor GW - I
    did a typcast that was invalid to widestrings....)


    Thanks

    Rainer

    Rainer Backes schrieb:
    > Hi Preston, Hi all,
    >
    > I have another Problem:
    >
    > Doing a ReadCursor I get the follwoing document:
    > <?xml version="1.0"?>
    > <SOAP-ENV:Envelope xmlns:xsd="http://www.w3.org/1999/XMLSchema"
    > xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
    > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
    > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
    > <SOAP-ENV:Header SOAP-ENV:encodingStyle="">
    >
    > </SOAP-ENV:Header>
    > <SOAP-ENV:Body
    > xmlns:types="http://schemas.novell.com/2003/10/NCSP/types.xsd"
    > SOAP-ENV:encodingStyle="">
    > <readCursorResponse> <items>
    > <item internet="1" xsi:type="Mail"
    > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    >
    > <id>48A9AFB2.EMA.test.100.1623972.1.69.1@1:7.EMA.t est.100.0.1.0.1@16</id>
    > <version>1</version>
    > <modified>2008-08-18T15:21:54Z</modified>
    > <container>7.EMA.test.100.0.1.0.1@16</container>
    > <created>2008-08-18T15:21:16Z</created>
    > <status/>
    > <msgId>48A9AFB2.EMA.test.200.200002C.1.5.1</msgId>
    > <messageId>&lt;48A9AF8C.10C8.00AF.0@bond.de&gt;</messageId>
    > <source>received</source>
    > <delivered>2008-08-18T15:21:54Z</delivered>
    > <security>Normal</security>
    > <subject>High Priority Sissi Assets 5.0% nach Steuern durch
    > die berühmte weiÃ*e Prinzessin</subject>
    > <distribution>
    > <from>
    > <displayName>"Rainer Backes"
    > &lt;rbackes@bond.de&gt;</displayName>
    > <email>rbackes@bond.de</email>
    > </from>
    > <to>Karl@bond-int.de</to>
    > <sendoptions>
    > <statusTracking>None</statusTracking>
    > </sendoptions>
    > </distribution>
    > <options>
    > <priority>Standard</priority>
    > </options>
    > <size>3981</size>
    > </item>
    > <item internet="1" xsi:type="Mail"
    > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    >
    > <id>48A9AFD1.EMA.test.100.1623972.1.6A.1@1:7.EMA.t est.100.0.1.0.1@16</id>
    > <version>2</version>
    > <modified>2008-08-18T15:24:14Z</modified>
    > <container>7.EMA.test.100.0.1.0.1@16</container>
    > <created>2008-08-18T15:21:59Z</created>
    > <status>
    > <opened>1</opened>
    > <read>1</read>
    > </status>
    > <msgId>48A9AFD1.EMA.test.200.200002D.1.4.1</msgId>
    > <messageId>&lt;7bfa9a84.004@gw-ema.bond-int.de&gt;</messageId>
    > <source>received</source>
    > <delivered>2008-08-18T15:22:25Z</delivered>
    > <security>Normal</security>
    > <subject>GWEMACON Fehler test.EMA</subject>
    > <distribution>
    > <from>
    > <displayName>&lt;GWEMACON@bond-int.de&gt;</displayName>
    > <email>GWEMACON@bond-int.de</email>
    > </from>
    > <to>Karl@bond-int.de</to>
    > <sendoptions>
    > <statusTracking>None</statusTracking>
    > </sendoptions>
    > </distribution>
    > <options>
    > <priority>Standard</priority>
    > </options>
    > <size>5032</size>
    > </item>
    > </items>
    > <status>
    > <code>0</code>
    > </status>
    > </readCursorResponse>
    > </SOAP-ENV:Body>
    > </SOAP-ENV:Envelope>
    >
    > The first item is the problem. My XML Library isn't able to read the
    > <subject> Element from the document.
    > Now my question: whose fault is it ? - Is my XML parser wrong or does
    > the POA code something strange?
    > The garbage characters should be Umlauts, but since 7.0.something
    > especially Mails from Exchange contain such carbage.
    >
    > Any ideas ?
    >
    >
    > Thanks
    >
    > Rainer
    >
    >



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •