This question tends to be more Windows XP in nature but I figured others may have seen or be able to assist with this question. The scenario is that following the last round of updates to my Windows XP base image Precison 390 workstations image.. run sysprep.. and following the restart going into a continuous loop. Windows XP splash screen comes up.. system freezes and then reboots.

The only updates made to my base image were as follows;

Windows Updates:
Update for Root Certificates
Malicious Software Removal Tool - March 2009 (KB890830)
Update for Windows XP (KB959772)
Update for Windows XP (KB967715)
Security Update for Windows XP (KB958690)
Security Update for Windows XP (KB960225)
Windows Live Update for Windows Live Sign-In Assistant (KB 967912)
Silverlight Update for Microsoft Silverlight (KB960353)
Update for Windows XP (KB961118)
XP Windows Malicious Software Removal Tool - February 2009 (KB890830)
Cumulative Security Update for Internet Explorer 7 for Windows XP (KB961260)
Update Rollup for ActiveX Killbits for Windows XP (KB960715)

Registry Changes:
Disable autorun.inf's

Application Updates:
Firefox 3.0.7
Windows Live Messenger 2009

I am using the same sysprep.inf file.. same procedure.. etc.. The image works great on other model types (Dell 745's/755's IBM S51's/M52's etc). Booting windows with boot logging reveals the following;

...Loaded driver KSecDD.sys
Loaded driver NDIS.sys
Loaded driver Mup.sys
Loaded driver agp440.sys
Did not load driver ACPI Uniprocessor PC
Did not load driver Audio Codecs
Did not load driver Legacy Audio Drivers...

No changes have been made to Hal.dll.. etc.. nor were changes made by my Windows Updates.

Any suggestions? Can anyone confirm similiar issues following the last round of Windows Updates?