Hello, I'm about to perform a NW 3.7 to 3.8 upgrade.

Some questions regarding prerequisites:

iManager 2.0.1 -> Can I safely install 2.0.2?
By the way, it requires JVM 1.4.1, is it OK if I use 1.4.2? (It says it's
not tested with BM3.8)

Novell eDirectory 8.7.1 -> Can I safely install 8.7.3?

Thanks for you kind help.