GW8 schema 1.02:

The following itemResponse was returned when I tried to retrieve a contact from the "Contacts" container of a task item. The contact has a single "ContactNote".

I get an error when trying to retrieve it (the .NET XML parser basically says that an XML element is supposed to be Base64-encoded, and that the "sequence length" of the supposedly-encoded block is not a multiple of 4.

The itemResponse came back all on one line, and the error said that the problem was on "line 1, character 1870). This corresponds to the end of the closing tag for the "gwt:data" element in the ContactNote (it's the gwt:data element in the gwt:attachment section of the ContactNote object):

<?xml version="1.0" encoding="UTF-8"?>
<s:Envelope xmlns:s="">
<gwTrace xmlns="" xmlns:h="">false</gwTrace>
<s:Body xmlns:xsd="" xmlns:xsi="">
<getItemResponse xmlns:gwt="" xmlns="">
<item xmlns:xsi="" xsi:type="gwt:Contact">
<gwt:id>49C2855A.PriDom.po1.104.1353763.1.10.1@56: 49414766.PriDom.po1.104.1353763.1.3.1@53</gwt:id>
<gwt:name>Sean Kirkby (gw7)</gwt:name>
<gwt:container>49414766.PriDom.po1.104.1353763.1.3 .1@53</gwt:container>
<gwt:PABGuid>/2@If "f 7\Fd! 0 !</gwt:PABGuid>
<gwt:displayName>Sean Kirkby (gw7)</gwt:displayName>
<gwt:emailList primary="">
<gwt:phone type="Office">(801) 921-6504</gwt:phone>
<gwt:organization>Armor Data Systems</gwt:organization>
<gwt:id>49D0CEB2.PriDom.po1.100.1353763.1.34B.1@2: A.PriDom.po1.</gwt:id>
<gwt:id>49D0CEB2.PriDom.po1.100.1353763.1.34A.1@65 </gwt:id>

When I created the note, I just typed in some random characters ("adfasdf" - drummed my left hand fingers on the "a" row of the keyboard).

Should this data be Base64-encoded?