Last week I had AFP running on my SLES10SP2, OES2SP1 server on my test tree with no problems. The last thing I did was add a NetWare 6.5 SP6 Server to the tree. This is the only NetWare server in the tree, and it is not configured for anything at the moment. All other servers are SLES10SP2, OES2SP1.

Today AFP is not working, I can't get the login dialog to pop up on my OSX workstation as it had been and I cannot get the iManager plugin to work. I select the server in iManager and am given the message: "Error: Storage Error" and "Could not get the CIM server data."

CIFS and NCP is still working fine on my Windows XP box. However, both AFP and CIFS are not connecting on OSX. They both give me "Error code -36" and " data on cifs:\\servername could not be read or written.

TID 3768604 seemed related and I ran the suggested fix, but had no change. I then set logging for openwbem to DEBUG. The log is attached. I did some searches on admin (the user I was logged into iManager as) but did not get anywhere. None of the terms I find in there get any hits on NOVELL: Worldwide.

I did find a thread in a forum, but it did not reach a conclusion.

NCP, AFP, and CIFS worked out of the box. Now they all broke out of the box

Before I break out my last Novell per-incident ticket, is there a different direction I should be going on this?


TID 3768604 came up on a Google search:

Could not create an instance of SambaUserArray. Error: Could not get the CIM server data. Error: CIM_ERR_INVALID_CLASS

Old Novell Forum Thread: