I've enabled Transparent HTTP proxy... and now I cannot access sites
using HTTPS. I've added the following lines in PROXY.CFG:

[TransparentHTTPS]
HTTPSPort1=443
HTTPSPort2=8080

.... and still HTTPS doesn't work. What else do I need to enable?

Jimmy