I have 3 servers novell.
a server is a master replica, while the other two servers are read / write replica.

On all servers I am running NW65 support pack 6 with post patches: NWLIB6J and LIBCSP6A.

I have no problems.

my question is this:
Having no problems is appropriate or not to upgrade to the latest version SP8?

The servers are a little old .. In fact we have bought them in 2001...
I do not want to have nasty surprises

Please could you tell me your opinion of experts?

The only thing is that I need to upgrade GroupWise.
I have not yet done but I will have to upgrade from GW703 HP1 to GW703 HP2.