I am using Backup Express 3.0 to backup our servers. The server I am having trouble restoring to is a Netware 6 SP5 and the master server for Backup Express is a Windows 2003 server.
When I try to restore a file on the Netware server I get an error 512 (error writing to file at destination). After talking to Backup Express support for DAYS they determined that the account doing the restore doesn't have sufficient privileges to the restore folder. The problem is that the account doing the restore is the Admin account that has full rights to EVERYWHERE. I even tries specifically adding admin as a trustee of the folder on the server I am trying to restore to; that didn't help.
When I tried to restore the files to a different server (NW6.5 SP7) I got the same error.
Here is the last email from Backup Express support detailing the issue:

As indicated in my previous email, debug TSA shows an error code for the
create command :

8c8aa4e0[main_thread ]0000e0f0[00308]: zCreate failed. ret:

The hex error 00005173 in decimal 20851 and if you check the Netware
return values page :

Novell Documentation

Note: scroll down and find the Return values section and choose link for
'Section 4.1 Return Values'.
Search for 20851 and you'll see the TSA return error is an Authorization
error and means :

zERR_NO_CREATE_PRIVILEGE: The caller does not have rights to create a
file object.

So the 'Admin.Crane' does not have sufficient rights to restore this
file to the locations on server. You could try a user with greater
rights, but if you have a user which you believe to have sufficient
rights then their maybe a problem in eDiretory and Netware support
should be consulted.

Any ideas on how I can get this file restored or why the admin account wouldn't have sufficient rights?

Thank you.