As a (sometimes) web developer I hate IE for making me have to write
special code to make my websites work in IE. I've been testing against
IE 8 since they released the beta versions. So far I've not had to
write any special code to make my existing sites work in it. While it
may not be politically or morally correct to try and force current IE
users to upgrade to version 8 I'm kind of thinking we should.

Of course the best method for doing this isn't to block access to the
website, but simply give a warning that the site isn't tested against
browsers prior to version 8 and it may not function properly. Of course
one should also give links to the major alternatives as well.

Viva La Revolucion!!