i'm messing around with zcm 10 in a windows test environment and I'm having a problem installing the remote listening agent on a machine running firefox 3.08. I get the error message that states the agent is not compatible with my web browser. I thought it worked with firefox, am I incorrect?