Well, hard topic but ....,,

Just spoke with Nokia since we're about to upgrade/change our phones.
Newer lines of Nokia's E-series phones which have been redesigned to
include their own, current Intellisync client.

Status of today is;
1. You can NOT install another version of Intellisync to the newer

2. The included Intellisync is NOT validated towards existing
Intellisync servers and Nokia can not (or will not ) say if it
could/should work at all.

So,, I guess that if you have a phone that works with GMS, right now
is NOT the time to get a new one.