Environment: ZCM 10.1.3 running on SLES 10 SP2 with all updates as of 2009-04-26
LDAP Source: Windows Active Directory
Windows Proxy: Manually installed on XP SP3 workstation

I have not been able to do a push deployment to our Windows workstations for some time now, perhaps since installing the 10.1.3 patch. I first discovered this when trying to run a deployment task to a Vista testing workstation, but it would fail each time. I will attempt to be as complete as possible here, so please forgive my verboseness if it helps in tracking down the problem.

Here are the steps I take to prepare a workstation for agent deployment (unless otherwise noted, I followed the instructions in the official documentation for deployment: see Novell Documentation):

  1. Install .NET 1.1, 2.0, 3.0, and 3.5 SP1 (for XP), or 3.5 SP1 (for Vista)
  2. Enable classic file sharing
  3. Set Remote Registry service to automatic; start service
  4. Disable Windows Firewall (at least until I can get this all to work!)
  5. Test the configuration
    1. Execute "net share" on the client to make sure IPC$ and ADMIN$ are being shared
    2. Connect to the remote registry from another machine
    3. Sometimes I also use PsExec to make sure remote code execution works (which it does at this point)

Next, I create a discovery task with the IP address of the client where I want to deploy the agent. I enter in correct local administrator credentials (hostname\username) or domain administrator credentials (if a domain member). Then I run the discovery task. No matter which client I try to discover, only MAC and WMI discovery methods succeed. WinAPI fails each time, which seems to be a clue.

After the discovery task has been run, the client is then found in the Deployable Devices section, but the operating system is listed as "Unknown Microsoft Windows." After that, I create a deployment task (again, using known good credentials) and launch it immediately. After a few seconds (~15 s.), it shows an error. The message returned reads,
Error: Credentials invalid. Please ensure that Classic file sharing is enabled on the target device.
In the loader-messages.log (/var/opt/novell/log/zenworks/loader-messages.log, log level on FINEST), an entry during discovery reads
I have tried entering the credentials numerous different ways (HOSTNAME\username, hostname\username, username, both local administrator and domain administrator accounts) to no avail.

Also, each time I attempt a deployment, the system message log (in the web interface, Configuration->System Information) shows the message
Setting 'com.novell.zenworks.settings.deployment.WinProxyT imeout' is not of the correct type (String). Returning the empty string{}
which I have seen before in this forum (see http://forums.novell.com/novell-prod...eployment.html), but no solution is given.

This thread (http://forums.novell.com/novell-prod...istration.html) is a similar problem, but the solution did not work since File and Printer Sharing for Microsoft Networks was already enabled on all of the workstations I tried.

I also have changed the Windows proxy assignment to different workstations where I manually installed the adaptive agent, but I always get the same result.

Since we have VLANs segmenting our network, I've tried assigning a proxy on the same VLAN as the client, but that doesn't help, either.

I am in a position to reinstall from scratch if there is no other solution, but I'd rather know what in the world is going on with the current installation. All of the above apply to clients running XP SP3 and Vista SP1.