After applying .NET 3.5 SP1 I am showing the version of .NET 2 being .3082 and not .3053. Will .3082 work withe agent? Is the TID correct??