I am running SLES 10sp2 OES2 SP1 on a server with a single SATA drive for swap and root (yeah I know) and a SATA array for data. I applied the latest RUG patches today and it said it was successful but because of the kernel update, it needed a reboot. When I rebooted I get:

root (hd0,0)
File system type unknown, partition type 0x82
kernel /boot/vmlinuz- root=/dev/disk/by-id/scsi-SATA_ST380013AS_4MR473ZA-part1 vga=0x317 resume=/dev/sda1 splash=silent

This server has had driver issues with the 3Ware SATA array before, but it has always booted, but just not loaded the SATA array until I updated the driver. This time, I cannot get it to boot even in failsafe. The older kernel is listed, but I get a "file not found" error if I try to boot from that.

So I booted from the SLES10 SP2 DVD in rescue mode. I can mount /dev/sda2 and see all of the files on the root partition. I can mount /dev/sdb1 and see all the files on the SATA array.

I modified /etc/fstab to remove the SATA array, but I still get the same error.

I ran fdisk on both disks and they show them as linux partitions

Is the type 0x82 the problem? How do I fix that when fdisk shows them correctly?

Thanks for any help!