Do I need to upgrade BM 3.6? If so, is it 3.8 or is there a way I can go to
3.7?

Cheers
Neil.