Hi there.

I've got an annoying problem with my backup settings.
It's a FS Primergy RX300 S4 server connected with a FibreCAT TX08 8-tape scsi library.

SLES10 had some problems detectings these scsi devices (got freezes during boot while checking scsi interfaces).
I've switched to SLES11 then. Theroretically 1st problem solved - system boots quite normally.

Tried to check server-tape library connections by uusing some basic mt or tar commands for ex.:
Code:
mt -f /dev/st0 status
mt: /dev/st0: rmtioctl failed: no medium
Code:
tar -czf /dev/st0 /home/1
tar: deletion of beginner `/' of file names (got that translated - my distro ain't english)
...and nothing happens...
Moving forward made some tests searching for tape library to be detected/connected:
Code:
cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: HP       Model: Ultrium 3-SCSI   Rev: D23B
  Type:   Sequential-Access                ANSI  SCSI revision: 03
Host: scsi0 Channel: 00 Id: 04 Lun: 01
  Vendor: FSC      Model: FibreCAT TX08    Rev: 1.52
  Type:   Medium Changer                   ANSI  SCSI revision: 05
Host: scsi1 Channel: 00 Id: 08 Lun: 00
  Vendor: FSC      Model: SAS Expander     Rev: 1.04
  Type:   Enclosure                        ANSI  SCSI revision: 03
Host: scsi1 Channel: 00 Id: 13 Lun: 00
  Vendor: FSC      Model: SAS Expander     Rev: 1.04
  Type:   Enclosure                        ANSI  SCSI revision: 03
Host: scsi1 Channel: 02 Id: 00 Lun: 00
  Vendor: LSI      Model: MegaRAID SAS RMB Rev: 1.12
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi1 Channel: 02 Id: 01 Lun: 00
  Vendor: LSI      Model: MegaRAID SAS RMB Rev: 1.12
  Type:   Direct-Access                    ANSI  SCSI revision: 05
Host: scsi2 Channel: 00 Id: 00 Lun: 00
  Vendor: HL-DT-ST Model: DVDRAM GSA-T50N  Rev: RW06
  Type:   CD-ROM                           ANSI  SCSI revision: 05

dmesg | grep scsi as follows (missed lines with sas/raid disks)
Code:
dmesg | grep scsi
Command line: root=/dev/disk/by-id/scsi-36003005700326640114a6ca31cad31d0-part2 resume=/dev/disk/by-id/scsi-36003005700326640114a6ca31cad31d0-part1 splash=silent crashkernel=256M-:128M@16M vga=0x31a
Kernel command line: root=/dev/disk/by-id/scsi-36003005700326640114a6ca31cad31d0-part2 resume=/dev/disk/by-id/scsi-36003005700326640114a6ca31cad31d0-part1 splash=silent crashkernel=256M-:128M@16M vga=0x31a
scsi0 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 3.0
scsi target0:0:0: asynchronous
scsi target0:0:1: asynchronous
scsi target0:0:2: asynchronous
scsi target0:0:3: asynchronous
scsi target0:0:4: asynchronous
scsi 0:0:4:0: Sequential-Access HP       Ultrium 3-SCSI   D23B PQ: 0 ANSI: 3
scsi0:A:4:0: Tagged Queuing enabled.  Depth 32
scsi target0:0:4: Beginning Domain Validation
scsi target0:0:4: wide asynchronous
scsi target0:0:4: FAST-160 WIDE SCSI 320.0 MB/s DT IU RTI PCOMP (6.25 ns, offset 64)
scsi target0:0:4: Domain Validation skipping write tests
scsi target0:0:4: Ending Domain Validation
scsi 0:0:4:1: Medium Changer    FSC      FibreCAT TX08    1.52 PQ: 0 ANSI: 5
scsi0:A:4:1: Tagged Queuing enabled.  Depth 32
scsi target0:0:5: asynchronous
scsi target0:0:6: asynchronous
scsi target0:0:8: asynchronous
scsi target0:0:9: asynchronous
scsi target0:0:10: asynchronous
scsi target0:0:11: asynchronous
scsi target0:0:12: asynchronous
scsi target0:0:13: asynchronous
scsi target0:0:14: asynchronous
scsi target0:0:15: asynchronous
...
scsi2 : ata_piix
scsi3 : ata_piix
scsi 2:0:0:0: CD-ROM            HL-DT-ST DVDRAM GSA-T50N  RW06 PQ: 0 ANSI: 5
scsi 0:0:4:0: Attached scsi generic sg0 type 1
scsi 0:0:4:1: Attached scsi generic sg1 type 8
scsi 1:0:8:0: Attached scsi generic sg2 type 13
scsi 1:0:13:0: Attached scsi generic sg3 type 13
sd 1:2:0:0: Attached scsi generic sg4 type 0
sd 1:2:1:0: Attached scsi generic sg5 type 0
scsi 2:0:0:0: Attached scsi generic sg6 type 5
st 0:0:4:0: Attached scsi tape st0
sr0: scsi3-mmc drive: 62x/62x writer dvd-ram cd/rw xa/form2 cdda tray
sr 2:0:0:0: Attached scsi CD-ROM sr0

Next goes /dev/tape directories:
Code:
ls /dev/tape/by-id -al
razem 0
drwxr-xr-x 2 root root 100 maj  4 15:51 .
drwxr-xr-x 4 root root  80 maj  4 15:51 ..
lrwxrwxrwx 1 root root   9 maj  4 15:51 scsi-1FSC_FibreCAT_TX08_TXDE65402286_LL0 -> ../../sg1
lrwxrwxrwx 1 root root   9 maj  4 15:51 scsi-32001000e11117844 -> ../../st0
lrwxrwxrwx 1 root root  10 maj  4 15:51 scsi-32001000e11117844-nst -> ../../nst0
Code:
ls /dev/tape/by-path -al
razem 0
drwxr-xr-x 2 root root 80 maj  4 15:51 .
drwxr-xr-x 4 root root 80 maj  4 15:51 ..
lrwxrwxrwx 1 root root  9 maj  4 15:51 pci-0000:05:04.0-scsi-0:0:4:0-0:0:4:0st -> ../../st0
lrwxrwxrwx 1 root root 10 maj  4 15:51 pci-0000:05:04.0-scsi-0:0:4:0-0:0:4:0st-nst -> ../../nst0
Code:
hwinfo --tape
42: SCSI 04.0: 10601 Tape                                       
  [Created at scsi.1459]
  UDI: /org/freedesktop/Hal/devices/pci_9005_8017_scsi_host_scsi_device_lun0_scsi_generic
  Unique ID: Er1e.y+VVM4dAGT8
  Parent ID: X3uT.RxhZXOTXHqB
  SysFS ID: /class/scsi_tape/st0
  SysFS BusID: 0:0:4:0
  SysFS Device Link: /devices/pci0000:00/0000:00:02.0/0000:01:00.0/0000:02:01.0/0000:04:00.0/0000:05:04.0/host0/target0:0:4/0:0:4:0
  Hardware Class: unknown
  Model: "HP Ultrium 3-SCSI"
  Vendor: "HP"
  Device: "Ultrium 3-SCSI"
  Revision: "D23B"
  Driver: "aic79xx", "st"
  Driver Modules: "aic79xx"
  Device File: /dev/st0 (/dev/sg0)
  Device Files: /dev/st0, /dev/tape/by-id/scsi-32001000e11117844, /dev/tape/by-path/pci-0000:05:04.0-scsi-0:0:4:0-0:0:4:0st
  Device Number: char 9:0 (char 21:0)
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #32 (SCSI storage controller)
Finally lsmod list:
Code:
lsmod
Module                  Size  Used by
joydev                 11392  0 
ide_disk               14664  0 
ide_cd_mod             33984  0 
nls_utf8                2160  1 
vmnet                  44564  5 
vmci                   55416  1 
vmmon                  73552  7 
af_packet              20280  0 
bridge                 56712  1 
stp                     3020  1 bridge
cpufreq_conservative     8384  0 
cpufreq_userspace       4204  0 
cpufreq_powersave       2248  0 
acpi_cpufreq            8120  0 
microcode              25032  0 
fuse                   57840  3 
loop                   17268  0 
dm_mod                 73904  0 
osst                   52928  0 
tpm_infineon            9820  0 
iTCO_wdt               12416  0 
iTCO_vendor_support     4268  1 iTCO_wdt
tpm                    17824  1 tpm_infineon
sr_mod                 15940  1 
bnx2                  177952  0 
tpm_bios                7000  1 tpm
st                     39020  0 
ppdev                   8208  0 
parport_pc             40152  0 
rtc_cmos               13000  0 
floppy                 62952  0 
container               4648  0 
i2c_i801               12756  0 
parport                40384  2 ppdev,parport_pc
rtc_core               21396  1 rtc_cmos
i5000_edac              9680  0 
button                  8328  0 
pcspkr                  3064  0 
cdrom                  36200  2 ide_cd_mod,sr_mod
rtc_lib                 3560  1 rtc_core
shpchp                 32244  0 
i2c_core               35200  1 i2c_i801
edac_core              47576  3 i5000_edac
ses                     7592  0 
pci_hotplug            31864  1 shpchp
enclosure              10000  1 ses
sg                     35376  0 
uhci_hcd               26872  0 
ehci_hcd               54004  0 
usbcore               195904  3 uhci_hcd,ehci_hcd
sd_mod                 35272  7 
crc_t10dif              2152  1 sd_mod
edd                    10272  0 
ext3                  140776  4 
mbcache                 9484  1 ext3
jbd                    61736  1 ext3
fan                     6016  0 
ide_pci_generic         4652  0 
ide_core              115068  3 ide_disk,ide_cd_mod,ide_pci_generic
ata_generic             6044  0 
ata_piix               21772  3 
libata                183232  2 ata_generic,ata_piix
dock                   14164  1 libata
megaraid_sas           37708  5 
aic79xx               182092  0 
scsi_transport_spi     26904  1 aic79xx
scsi_mod              178280  10 osst,sr_mod,st,ses,sg,sd_mod,libata,megaraid_sas,aic79xx,scsi_transport_spi
thermal                24392  0 
processor              49088  2 acpi_cpufreq,thermal
thermal_sys            14336  3 fan,thermal,processor
hwmon                   3720  1 thermal_sys
Perhapse I'm wrong but so far I see the tape drive IS detected and SHOULD be accessible in the system right? The tape is fully loaded - meaning all 8 tapes are fitted.

How cen I check/reinitiate the connection/accessibility to st0 (if the tape drive really is st0).

That thing begins to drive me crazy....

More than thankful for any help.