We are running ZDM 7 sp 1 IR3a HP3 on NetWare 6.5.8.

For those that do not want to look it up ... the ZENWorks PXE boot performs
a countdown from ~40 to 0 seconds and then reports an error message:

"ERROR: the server did not respond as requested in time".

After the error is message above is displayed the workstation will boot the
local OS. Unless the CTRL+ALT key combo is depressed at which time it will
bring up the PXE Menu - pretty much as expected, except that it should not
go through the 40 second countdown first.

Also it is not performing any imaging operations. For example I defined a
Rule for the Imaging Server Policy (ie for a non-registered workstation) but
the imaging process never started. Instead it did the countdown, displayed
the error message and then booted the local OS.

I also tried to get an imaging operation to be performed on a registered
workstation, but got the same result as described above.

I have tried reapplying the sp1 ir3a patch. No joy.
I have tried reapplying the sp1 ir3a hp3 patch. No joy.
I have tried a dsrepair - no meaningful errors reported and no joy.

The workstation and the zenworks server (which runs all zfd services) are in
the same subnet/vlan. The workstation gets a proper dhcp assigned ip
address, ip gateway, and transaction server ip address. The dhcp and pdhcp
services are also on the same server, and I have modified the pdhcp.ini file
for "USE_DHCP_PORT=0". Also the dhcp server has the global option 60 set to
PXEClient. All appears to me to be done correctly as per the documentation.
Finally, since we are heavily using vlans and have a routed network (Cisco)
the network admin has set the IP Helper on the various vlans. Clearly there
is not a problem with the initial dhcp/pdhcp communications as the
workstation gets all the ip info correctly and can perform a ZEN PXE boot to
the to PXE menu if you hold down the CTRL+ALT keys and wait 40 seconds...

So I am stumped.

Anybody got any ideas? Could it be a router/firewall issue - I suspect it is
because it was recently upgraded, whereas nothing on the ZEN side has been
touched since we applied HP3 in March. But what would I look for to
determine that is a network issue vs. an eDir issue
(rights/corruption/improper setup/etc.)

Clueless in Kelowna...