I tried to install the 10.2 update to the server in ZCC. The download went fine so I deployed it to the server (SLES 10 sp2 64). After a short time the status of the update went from Downloaded to Error. When I click on the error, I get:

An unexpected error occurred during the zone-wide pre-install actions. Check the loader-messages.log for details.

When I grep for error in the loader_messages.log file these are the errors I get:

[DEBUG] [6/3/09 1:13:14 PM] [] [Loader.MessageProcessorModule] [] [Exception in MessageFilterProcessor.run() during reading the zipFile 1240930873-0000-55bf55290ddce34ebeaf264c8660496f.zip: error in opening zip file] [] []
[DEBUG] [6/3/09 1:13:14 PM] [] [Loader.MessageProcessorModule] [] [java.util.zip.ZipException: error in opening zip file
[DEBUG] [6/3/09 1:17:47 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql] [com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:17:52 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql] [com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:17:58 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql] [com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:18:03 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql] [com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:18:09 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql] [com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:18:14 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql] [com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:18:19 PM] [] [Loader.SystemUpdateModule] [] [FINER: Error executing schema_update.sql. Max number of retries reached. Unable to succesfully execute this sql file] [] []
Caused by: com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
Caused by: com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: Error executing SQL: --
[DEBUG] [6/3/09 1:18:23 PM] [] [Loader.SystemUpdateModule] [] [FINEST: Attempting to set update status to ERROR with message: SystemUpdate.error.preglobalactions] [] []
[DEBUG] [6/3/09 1:18:23 PM] [] [Loader.SystemUpdateModule] [] [FINEST: Updated update (427b1afe45a1b7e8991f50231f0e7c82) status to ERROR] [] []



I tried to redo the ZCC update with the same outcome and then I tried to manually update with 'zman sui'.

Now I'm experiencing problems with ZCC. When I try to look at policies in the ZCC I get this error:

Attempt to forward user to object details page failed.: org.hibernate.exception.SQLGrammarException: could not execute query
See the ZENworks Control Center log file (zcc.log) for the full stack trace.


With this showing up in the zcc.log

03 Jun 2009 14:01:12 MessageUtil..........85 :Error: Attempt to forward user to object details page failed.
03 Jun 2009 14:01:12 ============== Exception (begin) ===========================
03 Jun 2009 14:01:12 Exception occured
03 Jun 2009 14:01:12
03 Jun 2009 14:01:12 Class....... com.novell.zenworks.datamodel.exceptions.InternalD ataModelException
03 Jun 2009 14:01:12 Message..... org.hibernate.exception.SQLGrammarException: could not execute query
03 Jun 2009 14:01:12 Logged at... Messages............313
03 Jun 2009 14:01:12 ============== Exception (end) =============================

Has anyone else experienced these problems?


jcm