Found ZCM 10.2 Update already downloaded in ZCC; Set Action for this Update to Deploy to Devices; Deployment started immediately on all workstations, not on the server; Had to set some of the workstations to "ignore" to let the server begin the update; After 24 hours still status pending was show for the ZCM server; Found in server update log that two msi modules are defect; Deleted 10.2 Update, started download again and after successfull download started deployment from scratch; Now the SP was also deployed on the server and status went to "Baselined"; First test looked OK, but only first tests:
Workstation registration not possible with following error message:
Newer agent version than server version: agentVersion: 10.2.0.25097 serverVersion: 10.1.3
Found TID 7002317; rpm -qa |grep novell-zenworks shows still old modules installed on the server:
novell-zenworks-temp-extras-langs-server-10.1.0-1
novell-zenworks-system-update-langs-server-10.1.0-1
novell-zenworks-zmglibs-10.1.0.0-0
novell-zenworks-zmgweb-10.1.0.0-0
novell-zenworks-certificate-authority-server-10.1.0-1
novell-zenworks-actions-10.1.3-1
novell-zenworks-core-langs-server-10.1.3-1
novell-zenworks-patch-management-10.1.3-0
novell-zenworks-zmgupdate-10.1.3.0-0
novell-zenworks-reports-server-10.1.3-1
novell-zenworks-common-jars-10.1.0.0-1
novell-zenworks-policies-langs-server-10.1.0-1
novell-zenworks-configure-langs-server-10.1.0-1
novell-zenworks-zmediacreator-10.1.0.0-0
novell-zenworks-tomcat-5.5.23-11
novell-zenworks-uninstall-10.1.3-1
novell-zenworks-thirdpartyimagingutils-10.1.1.0-0
novell-zenworks-zencore-agent-10.1.3-1
novell-zenworks-temp-extras-server-10.1.3-1
novell-zenworks-java-links-1.5.0_11-1
novell-zenworks-common-libs-10.1.0-1
novell-zenworks-zcm-langs-server-10.1.0-1
novell-zenworks-addon-image-langs-server-10.1.0-1
novell-zenworks-configure-server-10.1.3-1
novell-zenworks-pre_pkg-10.1.3.0-1
novell-zenworks-version-primary-server-10.1.3-1
novell-zenworks-deployment-server-10.1.3-1
novell-zenworks-zmgpxeclientfiles-10.1.3.0-0
novell-zenworks-zmgexplorer-10.1.2.0-0
novell-zenworks-bundle-10.1.3-1
novell-zenworks-jsvc-5.5.20-1
novell-zenworks-asset-management-langs-server-10.1.0-1
novell-zenworks-bundles-langs-server-10.1.0-1
novell-zenworks-preboot-langs-server-10.1.0-1
novell-zenworks-deployment-langs-server-10.1.0-1
novell-zenworks-zcm-server-10.1.0-1
novell-zenworks-zmgpolicy-10.1.0.0-0
novell-zenworks-certificate-authority-langs-server-10.1.0-1
novell-zenworks-policies-server-10.1.3-1
novell-zenworks-core-server-10.1.3-1
novell-zenworks-system-update-10.1.3-1
novell-zenworks-inventory-server-10.1.2-1
novell-zenworks-bundles-server-10.1.3-1
novell-zenworks-zmgbootcd-10.1.3.0-0
novell-zenworks-managed-devices-server-10.1.3-1
novell-zenworks-discovery-server-10.1.3-1
novell-zenworks-remote-management-langs-server-10.1.0-1
novell-zenworks-reports-langs-server-10.1.0-1
novell-zenworks-policy-10.1.1.0-1
novell-zenworks-system-update-server-10.1.3-1
novell-zenworks-preboot-server-10.1.3-1
novell-zenworks-primary-agent-10.1.3-1
novell-zenworks-java-utilities-server-10.1.0-1
novell-zenworks-inventory-langs-server-10.1.0-1
novell-zenworks-managed-devices-langs-server-10.1.0-1
novell-zenworks-discovery-langs-server-10.1.0-1
novell-zenworks-zmgmcast-10.1.0.0-0
novell-zenworks-asset-management-server-10.1.3-1
novell-zenworks-remote-management-server-10.1.3-1
novell-zenworks-addon-image-server-10.1.3-1
novell-zenworks-zmgservices-10.1.2.0-0
novell-zenworks-version-10.1.3-1

followed the Resolution and set /etc/opt/novell/zenworks/version.txt to 10.2;
Now Workstation registration works, but Bundle deployment results in tons or error logs in workstation object in ZCC:

The handler [NULL] was not found.

b06cae964debe703b136e95ef598ad67{[NULL];HandlerNotFound;NoRegisteredHandler;Copy Files Action}

Could not find a Handler associated with the following type: Install Files Action.

Could not find a results file for remote management policy. Message: Die Datei "C:\WINDOWS\TEMP\09a80ca8-1751-47d4-befc-c7d5164638db\-remote_management_policy-678201Output.xml" konnte nicht gefunden werden.. Missing file: C:\WINDOWS\TEMP\09a80ca8-1751-47d4-befc-c7d5164638db\-remote_management_policy-678201Output.xml.

Could not find a Handler associated with the following type: launcher configuration policy.

This error messages in the message log counts up > 500 messages after some minutes.

At the moment our ZCM environment is unusable after the update, we need urgent help or advice how to resolve (backrev to 10.1.3 or redeploy 10.2)

Any help is strongly appreciated.

Werner Seifert
Johannes Kepler Univercity Linz