SuSE 10.2 OES2 SP2 with latest AFP patches

AFP will not start on reboot...when trying to set it up to start in yast>system runlevels it will start, show that it is enabled, then when the settings are saved and you go back in it shows as disabled.

I tried to manually put a link to the the shell script in /etc/init.d/rc5.d but it still will not start.

I have other servers that do not have this problem. All the servers have a delay in the startup script:


case "$1" in

##Waiting for the volumes to come up after reboot
sleep 60
echo -n "Waiting for AFP initializing..."