Is SMT able to use the rug rollback function? I setup a server with Sles10sp2/OES2sp1, unpatched. I then created a checkpoint using rug. Then I patched the server using SMT. I then tried to do a rug rollack using the checkpoint I created and I got the following error:

ERROR: Dependency resolution failed:
Unresolved dependencies:
Updating novell-sss-3.4.1-29.i586[System packages] to novell-sss-3.4.1-26.i586[Novell Open Enterprise Server 2 SP1]
Establishing atom:novell-sss-3.4.1-29.i586[System packages]
novell-sss-3.4.1-29.i586[System packages] provides novell-sss == 3.4.1-29, but is scheduled to be uninstalled.
novell-sss-3.4.1-29.i586[OES2-SP1-Updates] provides novell-sss == 3.4.1-29, but another version of that package is already installed.
Can't satisfy requirement novell-sss >= 3.4.1-29 for atom:novell-sss-3.4.1-29.i586[System packages]
Establishing atom:novell-sss-3.4.1-29.i586[OES2-SP1-Updates]
This would invalidate atom:novell-sss-3.4.1-29.i586[System packages].
Marking this resolution attempt as invalid.

Would this happen if I/we were using ZLM as that is the 'full/paid for" product? Not the free product, SMT.