Is it OK to apply BM 3.8SP4 onto NW6.5SP3 + post patches?

I presume it is but just want confirmation.

We appear to have some odd issues accessing the amazon.co.uk website from a
server of ours the other side of a satellite link and I reckon a Proxy
update is probably required to solve it.

The issue only started a couple of months ago.

Karim C Kronfli
CNE 6