Just an FYI, since this affected me.

If you are upgrading to OES2 SP1 and you have one or more of your DA on OES2 SP1 using OpenSLP, you will want to make sure that all your Novell clients are 4.91 SP5 BEFORE you do the upgrade.

Otherwise, there's a bug in the srvloc.sys where it won't work correctly and your users won't be able to map their drives unless you use IP addresses.

Needless to say I had to upgrade about 2500 clients in one day after finding this out.

So if I can help someone else avoid the problem, great.