We have strange issues with clients running 6.5 sp4 and 8 hp2.
I am thinking of a bug but would like to know if others got this too.

We have 2 systems, external and internal.
External is hosting GWIA8.0 (hp2) + WEBAC8.0 (hp2) + MTA8.0 (hp2)
Internal is hosting all the POs 8.0 (hp2) (14 NW6.5 SP7 + 1 SLES10 SP1) + MTA8.0 (hp2)

The external agents are served by a SLES10 SP1 server.
One internal PO and the internal MTA are on another SLES SP1 server.
The other internal POs are on separate NW6.5 SP7 servers.

Our main issues :
1/ Some elements saved in "Work in progress" appears garbled when reopened (all special characters are transformed in signs), in the client (nothing to do with the webaccess issue fixed by hp2)
2/ Some sent emails from the client (internally or externally) are garbled when opened by the recipients (same problem as 1)
3/ Some sent emails from the client (internally or externally) are completely messed up : the recipient sees the message source (MIME code) instead of the message itself.

I do not have confirmation that the problem appears also with the WebAccess, we have few remote users.

The problem is that those issues appears at random, on different computers, on different POs, with different users sending to different users, with client 6.5 or 8.0.
So it is very hard to reproduce.
No clues in the log files of the MTA, PO, GWIA.

What we tried :
- We tried changing every agent to UTF-8 encoding : running gwcheck on user databases, with setmimeencoding option, modifying webacc.cfg, changing the client options. The problem still appears at random.
- We updated everything (except 6.5 clients) to 8.0 hp2, it solved issues relative to the webaccess, but none regarding the above problems.
- We have checked the MIME code for emails with problem 3, copy-pasting it in a telnet session on the smtp port : the new generated email arrives ok, so not a formatting problem.

It really looks like a client bug (eventually a MTA/PO bug ?)
Clients are running 6.5 SP4 (Fr) or 8.0 hp2 (Fr).

We setted up client mime encoding back to ISO-8859-1 (setmimeencoding=41), Western europe encoding that is (French actually).
The 6.5.4 clients use the "Windows standard" encoding.

The "locale" of linux servers :
I have browsed the forums for similar issues but nothing helped.

Thanks for your help !
This problem is very embarassing since it can touch every single user at random, not knowing if the recepient is getting the email correctly.