I also went to upgrade to ZLM73 (from ZLM72 IR2 HP3 on SLES 10 SP1_x86_64), and the zlm-upgrade failed after a few minutes with the following message:

Traceback (most recent call last):
File "/mnt/data/zlmupgrade.py", line 455, in ?
File "/mnt/data/zlmupgrade.py", line 217, in main
novell_zmd_version = string.split(ZLMZMDLib.rpmPackageVersion('novell-zenworks-zmd'), '.')[:3]
File "/usr/lib64/python2.4/string.py", line 292, in split
return s.split(sep, maxsplit)
AttributeError: 'NoneType' object has no attribute 'split'

When i restart ZLM with zlm-config --restart, all Services came up except eDir.

When i
Restarting all services...

Successfully restarted Novell ZENworks Imaging Service
Failed to restart Novell eDirectory
Successfully restarted Novell ZENworks Server Management
Successfully restarted Novell ZENworks Server
Successfully restarted Novell ZENworks Preboot Policy Daemon
Successfully restarted Novell ZENworks Management Daemon
Successfully restarted Novell ZENworks Loader

eDir seems to have a problem.

The command: rpm -qa|grep NDS show me the following:

I think this was a eDir-related Problem and saw that all NDS-Commands were answered with the following message:

error while loading shared libraries: libndssdk.so.1: cannot open shared object file: No such file or directory

I found, that the file libndssdk.so.1 is included in the directory /opt/novell/eDirectory/lib64

lrwxrwxrwx 1 root sys 18 Jun 30 07:52 libndssdk.so -> libndssdk.so.1.0.0
lrwxrwxrwx 1 root sys 18 Jun 30 07:52 libndssdk.so.1 -> libndssdk.so.1.0.0
-rwxr-xr-x 1 root sys 989345 Jul 6 2008 libndssdk.so.1.0.0

PATH-problems? Ok, then let's have a try:

1. export PATH=$PATH:/opt/novell/eDirectory/lib64 (to ensure that there are no Path-related problems)
2. vi /etc/ld.so.conf (add the path /opt/novell/eDirectory/lib64)
3. ldconfig
4. ndsconfig upgrade -a admin.system -w password -c -j
5. zlm-config --status
6. All services (include eDir) are up and running
7. zlm-config --restart (to see what happens)
8. Starting Webfrontend, it works.

Now (for testing purposes) i've tried to do a new zlm-upgrade, but it ends with the same error.

When i'm working on the Web-Gui and look through my registered clients, the following error message occurs by clicking on a client-machine:

Fehler: Attempt to forward user to object details page failed.: Could not load Device from database: 178fdf4f446249338258948cdc5619c9
Im Tomcat-Protokoll finden Sie die vollstndige Stapelverfolgung.

I think the database is damaged. Is there a solution to pepair or to reorg the database (postgresql). I have a backup from yesterday from my database and from eDir.
The same when i try to delete a client-machine:
Fehler: Objekt nicht gelscht: org.hibernate.PropertyAccessException: IllegalArgumentException occurred calling getter of com.novell.zenworks.datamodel.extensions.devices.O peratingSystem.operating_system_id

Has anybody any idea what i can do?

Best regards