Hi,

Kinda new to multipath for linux but here is my problem..

I have a 5 node mixed cluster. Just for testing purposes. i have 5 lun's assigned to this cluster (which reside on a EMC Clariion CX-320). The HBA's (dual) in the server are Qlogic (qla2xxx).

I am testing the multipath by disabling one port on the FC switch, when i do this the server reboots (tried both switches, so active/stand-by path)...instead of continue running via 1 path..

the only thing i get before the reboot is : kernel: qla2xxx 0000:0c:00.0: LOOP DOWN detected (2)

i have configured /etc/multipath.conf with only this line :

defaults {
default_features "1 queue_if_no_path"
}

i have configured /etc/modprobe.d/qla2xxx with this line :

options qla2xxx qlport_down_retry=1 ql2xfailover=0 ql2xretrycount=5

(before above line was in /etc/modprobe.conf.local)

The nss resource (from ncs) which is assigned to that server at the moment goes into comatose when the server reboots..

this is what multipath list (multipath -ll)

36006016034911d00e0973a70c555de11 dm-1 DGC,RAID 5
[size=2.0G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:3 sdi 8:128 [active][ready]
\_ 1:0:0:3 sde 8:64 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 1:0:1:3 sdv 65:80 [active][ready]
\_ 2:0:1:3 sdn 8:208 [active][ready]
36006016034911d009eb0c851c555de11 dm-2 DGC,RAID 5
[size=5.0G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:2 sdh 8:112 [active][ready]
\_ 1:0:0:2 sdd 8:48 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 1:0:1:2 sdu 65:64 [active][ready]
\_ 2:0:1:2 sdm 8:192 [active][ready]
36006016034911d006ea0f20bbe3bde11 dm-3 DGC,RAID 5
[size=2.0G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:1 sdg 8:96 [active][ready]
\_ 1:0:0:1 sdc 8:32 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 1:0:1:1 sdt 65:48 [active][ready]
\_ 2:0:1:1 sdl 8:176 [active][ready]
36006016034911d00beb1bc43bd60de11 dm-0 DGC,RAID 5
[size=50G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 1:0:0:4 sdr 65:16 [active][ready]
\_ 2:0:0:4 sdj 8:144 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 1:0:1:4 sdw 65:96 [active][ready]
\_ 2:0:1:4 sdo 8:224 [active][ready]
36006016034911d0004c93541be3bde11 dm-4 DGC,RAID 5
[size=200G][features=1 queue_if_no_path][hwhandler=1 emc]
\_ round-robin 0 [prio=2][active]
\_ 2:0:0:0 sdf 8:80 [active][ready]
\_ 1:0:0:0 sdb 8:16 [active][ready]
\_ round-robin 0 [prio=0][enabled]
\_ 1:0:1:0 sds 65:32 [active][ready]
\_ 2:0:1:0 sdk 8:160 [active][ready]

The lun / nss resource where i am testing with is the 50GB..

i can't imagine this is because of running a mixed cluster right?!!

here is the partition info:
Filesystem Size Used Avail Use% Mounted on
/dev/sda3 63G 3.1G 57G 6% /
udev 2.0G 412K 2.0G 1% /dev
/dev/sda1 244M 9.7M 221M 5% /boot
/dev/evms/NSS 50G 942M 50G 2% /opt/novell/nss/mnt/.pools/NSS
admin 4.0M 0 4.0M 0% /_admin
NSS 50G 789M 50G 2% /media/nss/NSS


Hope anyone can help me out here... if more info is needed let me know pls.

Thanx in advance..