I am on ZCM 10 SP2. I have created a deployment task with a registration key. For the past 2 weeks, I was able to use this deployment task and deploy the agent to about 10 PCs.

However, for the past 2 days, I used the same deployment task (just edit the devices that I want to deploy the agent) to three Windows XP SP2 PCs, 2 failed and one deployed and registered properly using the registration key.

The 2 that failed both return the following error:
error -21, message: Could not determine device type from <OS> tag: unsupported.

On one PC, I used add/remove program to remove the agent, reboot then access the URL to manually install the agent. However, it still won't register and gave me the same error.

I have opened a SR with Novell and asked to escalate the issue. However, I was told that I could wait at least couple days before the Novell Engineer can get to it:(

I wonder if others have seen the same error and if there is a quick fix for it. At the discovery task, the PCs was knows with Windows XP OS.

Thanks in advance.