I just put ZENworks Imaging Driver Update for June 2009 on my server, to
support the Realtek 8111 NIC, but it doesn't work. I've read a few things about
that kernel version (2.6.27) not working with the r8169 module and 8111B Card,
but older kernels do, as well as the newer 2.6.29. (this came from an ubuntu
forum, so I can't verify).

Is there still a supported method of manually updating the kernel for ZCM
imaging PXE environment? Realtek lists the driver as included in the kernel, so
I can't downloaded an updated version of the module. I've tried backreving to
the Zen7SP1IR3a_HP3-May09 and the ZCM10.1.3-February09 images, but neither of
those worked either.

the behvior is this:
The card will not get an address from DCHP, and the kernel log(Alt-F4) says
"eth0: link down" immediately after boot. If you remove the cable, the log says
"eth0: link down" again, and when you replace the cable it says "eth0: link
down" yet again. The driver is recognizing the physical cable going in and out,
but never sees the link come up. Assigning a manual IP by using "ifconfig eth0
<ip> netmask <mask>" doesn't work either.

any ideas?