I've been having to go through a manual process to update our field servers from 10.1.3 to 10.2 and on one I received the following error message when executing the zac command:

Corlib not in sync with this runtime: expected corlib version 68, found 56.
Loaded from: /usr/lib/mono/2.0/mscorlib.dll
Download a newer corlib or a newer runtime at Mono Daily Binary Packages.
I followed the instructions, setup a source to Novell's website to update Mono but when going to upgrade it I was told the dependency libgdiplus0 did not have a resource. I did more digging and could not find any more information and some mentioned this may break other products that depend on CASA such as DHCP so I came to a halt.

Any ideas? We have not been upgrading Mono unless something had gone haywire during the install of 10.2 on this server resulting in another partial upgrade where something needs a newer version of Mono?

Next I'm going to check for the Mono install packages from ZCM to see if they can be installed manually somehow.