I didn't know which other forum to pick :-/ (I already tried edir Linux) ... but I encounter serious troubles on using the functions addUser & removeUser of the NetWare management files on the _admin volume as described in http://http://developer.novell.com/documentation/vfs/vfs__enu/data/afvxgpi.html
on a Novell OES1 Linux server (with all current (official) patches applied)

While manipulating user quotas via the virtual file /_admin/Manage_NSS/manage.cmd works like a charm I cannot seem to get the edirectory manipulating functions by means of the virtual file /_admin/Manage_NSS/NDS.cmd to work :-(.

Commands (with - of course - virtualIO datastream set to "command") like


  <fullName>Peter Pan</fullName>
  <userDescription>Auto added user</userDescription>

always end up with an error code -672 (no access) like in:

<result value="-672"><description>Error adding user to NDS</description><reporter>../../public_core/sharedsrc/manageNDS.c.h[3238]</reporter><name>ERR_NO_ACCESS</name></result>
<result value="0"><description>zOK</description></result>

Where is the error? Does the VFS interface need any special rights in edir or elsewhere (I already tried to give "PUBLIC" every right - for a very short test period *g*)?
I am perplex and don't know where to look to get this issues solved :-(.

Thank you very much for reading!