I'm now using for years same configuration with a couple of NetWare
installations. These are some small networks where I see no great benefit in
activating a local nameserver, so the DHCP server distributes the IP of the
firewall's DNS proxy to all clients which works fine + the server has this
same firewall DNS entry in sys:/etc/resolv.cfg. None of the servers have a
'domain ...' entry in the resolv.cfg because this caused me already trouble
in the past, but once I deleted it all worked fine.
That works fine with NetWare 6.0 SP5, NetWare 6.5 up to and including SP6. I
have a SP7 server in my own network, and this server worked fine with SP6,
but now with SP7 the server does no longer resolve. Another testbox which I
have installed and running inside VmWare is a fresh installed SP8 which also
fails to resolve. Even more strange is that I have another SP7 server at one
of my customers with exactly same setup + same firewall which works ...
After further digging I did downdate the TCP.NLM on my SP7 and SP8 server to
the one which ships with SP6:
Novell TCP/IP Stack - Transport module (NULL encryption)
Version 6.80.02 19 September 2006
and with this NLM both SP7 and SP8 can now resolve again ...
a friend reported exactly same issue with a fresh installed SP8, and I did
just send him the SP6 TCP.NLM, and waiting for his reply if that works for
him too; another friend with an updated SP8 server tells me though that
resolve works fine for him ...
I'm more than confused about this, and would expect that it must be some
setting somewhere, but where the heck is something else to cvonfigure if not
in resolv.cfg?
Also I found this post:
which might be related to my problem ...
If I try queries with NSLOOKUP.NLM on SP7 I get always immediately a timeout
reply - although the timeout is by defsult 2 secs, and even if I set it to
10 secs it still replies immediately with a timeout error.
NSLOOKUP.NLM from SP8 seems to be a completely other thingy - its size
growed from ~98kb to 1+MB, it does no longer support ? for help, and most
important it does abend for me with the message:
SYS:SYSTEM\NSLOOKUP.NLM: isc_socket_bind: unexpected error
of course all of the above errors only occur with the shipping TCP.NLM of
SP7 and SP8, after the downdate all works fine.

Anybody has seen any similar strange things?