I am running OES2SP1 on Linux, latest patch level on everything,
running the AFP service, sharing an NSS volume to OSX 10.5.7 clients.

I got it working yesterday, with the OES2 server running in
VirtualBox, but the I/O performance was not very good, so I switched
back to running my OES2 server in Xen.

Now, having set it all up again (everything identical, just had to
create pool, nssvol and share it using AFP (+ setting password
policy). This VM was from the same snapshot I used before setting it
up in VBox.

So, the configuration is similar, I tried to do everything the same
way. But I have one problem today that I didn't face yesterday: When I
from the Mac copy some file containing a comma (or maybe other special
characters, like ';', I get an error:
The Finder could not complete the operation because some data
in "04-Is,is,is.m4a" could not be read or written.
(Error code -36)

From Apple's doc:
An "error code -36" alert in Mac OS X indicates that data cannot be
sent or received by the operating system for some reason.

My first thought would be the namespace of the NSS volume, but I know
I left it on "long" yesterday. (And all four are supported.) And then
I had no trouble. But of course I also tried changing it to mac, but
that made no difference.

So, do you have any hints on what to check?
I really cannot understand what I have done differently today.

Best regards,